Welcome to SP!  -
Areas & RangesMountains & RocksRoutesImagesArticlesTrip ReportsGearOtherPeoplePlans & PartnersWhat's NewForum

Report Bugs Here

Suggestions and comments about SummitPost's features, policies, and procedures. Post bugs here.
 

Re: Report Bugs Here

Postby Dow Williams » Thu Feb 07, 2013 5:40 pm

replace_object() INSERT INTO `objects` SET `object_id`=NULL,`type_id`=1,`last_edit`=NOW(),`creation`=NOW(),`last_edit_user_id`='19503',`created_user_id`='19503',`show_toc`='Yes',`construction`='No',`object_name`='Disneyland Dome, 5.9-5.12a',`query_name`='Disneyland Dome climbs routes, Jungle Cruise climb route, Enchanted Stairway climb route, Mental Bankruptcy climb route traverse, Wonderland South climbs routes, Joshua Tree National park climbs routes, Jtree climbs routes, Dow Williams Joshua Tree Climbing',`continent`='North America',`country`='United States',`province`=NULL,`state_province`='California',`county`=NULL,`latitude`='34.046117',`longitude`='-116.144933',`activities`='Trad Climbing, Sport Climbing',`seasons`='Spring, Fall, Winter',`elevation`=NULL,`object_body_ft`='
User Avatar
Dow Williams

 
Posts: 2349
Joined: Mon Jul 12, 2004 1:59 pm
Location: Utah and Canadian Rockies
Thanked: 219 times in 101 posts

Re: Report Bugs Here

Postby Dow Williams » Thu Feb 07, 2013 5:41 pm

only item I did not chose was county and elevation (not relevant to walls)....I sure would not make County a requirement...even for US additions...never got a fail this detailed before...always the short version
User Avatar
Dow Williams

 
Posts: 2349
Joined: Mon Jul 12, 2004 1:59 pm
Location: Utah and Canadian Rockies
Thanked: 219 times in 101 posts

Re: Report Bugs Here

Postby rgg » Thu Feb 07, 2013 6:47 pm

Dow Williams wrote:replace_object() INSERT INTO `objects` SET `object_id`=NULL,`type_id`=1,`last_edit`=NOW(),`creation`=NOW(),`last_edit_user_id`='19503',`created_user_id`='19503',`show_toc`='Yes',`construction`='No',`object_name`='Disneyland Dome, 5.9-5.12a',`query_name`='Disneyland Dome climbs routes, Jungle Cruise climb route, Enchanted Stairway climb route, Mental Bankruptcy climb route traverse, Wonderland South climbs routes, Joshua Tree National park climbs routes, Jtree climbs routes, Dow Williams Joshua Tree Climbing',`continent`='North America',`country`='United States',`province`=NULL,`state_province`='California',`county`=NULL,`latitude`='34.046117',`longitude`='-116.144933',`activities`='Trad Climbing, Sport Climbing',`seasons`='Spring, Fall, Winter',`elevation`=NULL,`object_body_ft`='


Just a guess: could the value that follows query_name be too long? If it is, then, ideally, the result shouldn't be something like 'unknown error', but either the value should be truncated or an understandable message be given. And preferably the field in the Create Page dialog should not allow values that are too long in the first place.
As I said, just a guess, it might be something completely different.
User Avatar
rgg

 
Posts: 553
Joined: Sat Oct 02, 2010 7:15 pm
Location: Amsterdam, Netherlands
Thanked: 135 times in 105 posts

Re: Report Bugs Here

Postby Dow Williams » Thu Feb 07, 2013 7:55 pm

no, I tested it without the long query, just allowed it to self fill as it is set up to do with the wall name, same "replace object" fail....of course you want a longer query like this or a mountain or wall would not do well in search results..in all previous SP versions, a query this long was never an issue and worked well in search engines... can't imagine messing that aspect up in this rewrte, but it would not totally surprise me that someone working on it might not have any idea why that might be important
User Avatar
Dow Williams

 
Posts: 2349
Joined: Mon Jul 12, 2004 1:59 pm
Location: Utah and Canadian Rockies
Thanked: 219 times in 101 posts

Re: Report Bugs Here

Postby Dow Williams » Fri Feb 08, 2013 12:18 am

gotcha .....before I believe it automatically cut it off Matt...in other words, go revisit or re edit a page and if one looked close enough, his/her query was chopped if it got to long, no error messages necessary....weird thing is I was sure I re submitted a new page without the long query trying to figure this out and still got the error...but perhaps that is what started it...thanks
User Avatar
Dow Williams

 
Posts: 2349
Joined: Mon Jul 12, 2004 1:59 pm
Location: Utah and Canadian Rockies
Thanked: 219 times in 101 posts

Re: Report Bugs Here

Postby ywardhorner » Fri Feb 08, 2013 12:36 am

Montana Matt wrote:
ywardhorner wrote:When trying to upload/attach an image, 2 out of 3 times I end up with a blank page saying Internet Explorer Cannot Display The Page and I have to start over.

Which process are you talking about here? Uploading is very different than attaching unless you're talking about the process of uploading AND attaching?
ywardhorner wrote:Ditto when editing sections on the pages (ie. to insert an image). I either get the IE error page or a blank(ish) SP page showing just the text that normally appears at the bottom.

Sounds to me like a connectivity problem on your end, not anything wrong with the editor or the site.
ywardhorner wrote:Running IE9 on Win 7.

Have you tried a different browser.



hi Matt -- I'm talking about the link in the sidebar that you get when editing a page. Add Image -- Create New --> and then that whole process. However, I also get the problem when I edit a page. After clicking the Submit Changes button, I get the problems I described in my earlier post. It's not always the IE error page, sometimes it's a blank SP page with just the text at the bottom. Next time, I'll grab a screenshot and post it.

I do use Chrome as well as IE but haven't tried this process in Chrome. Personally, I'd be fine just using Chrome when I want to be on SP but lots and lots of people use IE.
Connect with me on Twitter: https://twitter.com/YWardHorner or check out my blog http://blog.yvettewardhorner.com
User Avatar
ywardhorner

 
Posts: 82
Joined: Tue Jun 22, 2010 1:59 am
Location: Wyoming, United States
Thanked: 29 times in 15 posts

Re: Report Bugs Here

Postby yatsek » Fri Feb 08, 2013 3:21 pm

Why does today's POTD (the climbing bear) not show on the front page? A bug or have wildlife photos been banned from the front?
User Avatar
yatsek

 
Posts: 848
Joined: Wed Aug 27, 2008 4:04 pm
Location: Poland
Thanked: 49 times in 38 posts

Re: Report Bugs Here

Postby Bob Sihler » Fri Feb 08, 2013 3:52 pm

yatsek wrote:Why does today's POTD (the climbing bear) not show on the front page? A bug or have wildlife photos been banned from the front?


There is a good chance it will be POTD tomorrow. Montana Matt and Chad can explain why better than I can, so I'll yield the podium to them on this one.
"Alcohol is like love. The first kiss is magic, the second is intimate, the third is routine. After that you take the girl's clothes off."

--Terry Lennox, The Long Goodbye (Raymond Chandler)
User Avatar
Bob Sihler
Forum Moderator
 
Posts: 7865
Joined: Mon Aug 23, 2004 3:20 pm
Location: Herndon, Virginia
Thanked: 2188 times in 1224 posts

The following user would like to thank Bob Sihler for this post
yatsek

Re: Report Bugs Here

Postby mrchad9 » Fri Feb 08, 2013 4:32 pm

POTD is the best pic from the last 48 hrs instead of the last 24. That way it has been submitted a full 24+ hrs rather than less than 24 hrs. So it will be one day delayed from what it was before.

Implemented this for two reasons:

1. Allows more members time to vote on what they like, especially if they are used to using the best photos in a day link on the home page.
2. Removes some of the incentive to post photos just after midnight. Now pics submitted at 8:00 AM, or noon, or even in the afternoon have time to rise to the top. Previously afternoon submissions were at a severe disadvantage.

Wildlife photos will never be banned from the process or even a consideration. It is entirely automated and up to the members' votes to pick the winner.
User Avatar
mrchad9

 
Posts: 4237
Joined: Thu Jul 02, 2009 12:01 am
Location: San Ramon, California, United States
Thanked: 1222 times in 829 posts

The following user would like to thank mrchad9 for this post
Bob Sihler, Kiefer, yatsek

Re: Report Bugs Here

Postby mrchad9 » Tue Feb 12, 2013 12:56 am

OK here is a real trivial bug... but I will post it anyway in case it is super easy to fix.

In the climber's log on our profile pages sometimes the parent of a page doesn't display. This often happens when a object has something attached as 'related'. I have cleaned some of these up, as generally making something a parent or child is a better fit anyway. But ideally we would either get rid of 'related' or make it so that it doesn't cause this issue.

But sometimes there is something called 'Resources' that does this. Where does this 'Resources' come from? It isn't an attachment. Look at the Mount Shasta page for example (pic below). And when I clicked it, it took me to Groupon.com!

Resources.jpg
Resources
Resources.jpg (41.59 KiB) Viewed 275 times
User Avatar
mrchad9

 
Posts: 4237
Joined: Thu Jul 02, 2009 12:01 am
Location: San Ramon, California, United States
Thanked: 1222 times in 829 posts

Re: Report Bugs Here

Postby Josh Lewis » Tue Feb 12, 2013 1:09 am

I've noticed that for a while, I didn't put it together that it was because of "related objects".

As for the resources, I figured it was an excuse to put in another ad. :wink: I say it should be renamed because it's misleading.
My Websites: Personal Website · PeakBeta · AceMaps
User Avatar
Josh Lewis

 
Posts: 2776
Joined: Thu Jan 06, 2011 11:12 pm
Location: Lynnwood, Washington, The Cloudiest Place on Earth, United States
Thanked: 673 times in 434 posts

PreviousNext

Return to Site Feedback

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

© 2006-2013 SummitPost.org. All Rights Reserved.