Welcome to SP!  -
Areas & RangesMountains & RocksRoutesImagesArticlesTrip ReportsGearOtherPeoplePlans & PartnersWhat's NewForum

bugs in MBpost (and SP ?)

Suggestions and comments about SummitPost's features, policies, and procedures. Post bugs here.
 

bugs in MBpost (and SP ?)

Postby visentin » Tue Jun 18, 2013 2:04 pm

http://www.mbpost.com/user-profile-imag ... 0/c-264341
When I try to visualize the parent page I can't.
I observed a similar thing for some photos for which the caption was too long. I was able to display them when I reduced it.
One of such pictures :
http://www.mbpost.com/after-the-race/287022/c-287001
Other bug (but I think distinct), photos with a size of 5Mpx do not appear correctly like this one :
http://www.mbpost.com/finisher/287108/c-264487
Eric
User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby Montana Matt » Tue Jun 18, 2013 5:34 pm

Thanks for pointing these out Eric. I was aware of the issue with the large photos not appearing correctly, but it seems to be isolated to MBPost.com and I haven't been able to figure out what is causing it or been able to repeat it myself, though I know where the problem lies (data isn't being inserted into one of the tables when the photo is uploaded).

As for the link to the parent page not working, I've not noticed this before and am not sure what is causing it upon immediate viewing, but will take a look.
User Avatar
Montana Matt
Site Admin
 
Posts: 1142
Joined: Sun Apr 11, 2004 10:06 pm
Location: Ashland, Oregon, United States
Thanked: 342 times in 185 posts

Re: bugs in MBpost (and SP ?)

Postby visentin » Tue Jun 18, 2013 8:06 pm

Thanks.
I'm not sure if there is not a difference between the two ways of posting a picture:
- first method the usual one with create page -> picture (on top)
- second method, add picture -> add new (left panel when on a page)
User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby visentin » Thu Aug 08, 2013 2:42 pm

Matt, is there any news about this ? the third bug I mentioned is occuring quite often lately on MBPost, I don't see it on SP so perhaps there is a fix ?
Thanks !
Eric
User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby Montana Matt » Tue Aug 13, 2013 6:20 pm

The code on MBPost and SP is identical, so I don't know why it is happening. I haven't had time to look into it yet.
User Avatar
Montana Matt
Site Admin
 
Posts: 1142
Joined: Sun Apr 11, 2004 10:06 pm
Location: Ashland, Oregon, United States
Thanked: 342 times in 185 posts

Re: bugs in MBpost (and SP ?)

Postby Josh Lewis » Thu Aug 15, 2013 9:51 pm

visentin, an effort may be made this Fall for bugs on mbpost. We know there are some things that aren't quite right. I've got styling to do for mbpost as well.
My Websites: Alpine Josh · Alpine Ascent · AceMaps
User Avatar
Josh Lewis

 
Posts: 2303
Joined: Thu Jan 06, 2011 11:12 pm
Location: Lynnwood, Washington, The Cloudiest Place on Earth, United States
Thanked: 498 times in 330 posts

Re: bugs in MBpost (and SP ?)

Postby visentin » Mon Aug 19, 2013 12:36 pm

User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby visentin » Mon Sep 02, 2013 8:20 am

User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby Josh Lewis » Mon Sep 02, 2013 7:07 pm

Wow! That's bad! Haven't seen a photo ever load like that.
My Websites: Alpine Josh · Alpine Ascent · AceMaps
User Avatar
Josh Lewis

 
Posts: 2303
Joined: Thu Jan 06, 2011 11:12 pm
Location: Lynnwood, Washington, The Cloudiest Place on Earth, United States
Thanked: 498 times in 330 posts

Re: bugs in MBpost (and SP ?)

Postby visentin » Tue Sep 03, 2013 8:48 am

Lots of tehm on MBPost. THese are only couple of examples.
User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby Montana Matt » Tue Sep 03, 2013 7:49 pm

Yes, I'm not sure why it happens, but some information is not being inserted into the database when photos are uploaded. Thus on the photo page, the code isn't aware of all of the available sizes of photos and it displays the original when it should be displaying the medium resized image.
User Avatar
Montana Matt
Site Admin
 
Posts: 1142
Joined: Sun Apr 11, 2004 10:06 pm
Location: Ashland, Oregon, United States
Thanked: 342 times in 185 posts

Re: bugs in MBpost (and SP ?)

Postby visentin » Tue Sep 17, 2013 10:12 am

Montana Matt wrote:The code on MBPost and SP is identical

By the way, taking you to the word ( :) ), there should be the GPX feature on MBPost. Well needed !
User Avatar
visentin

 
Posts: 1439
Joined: Sun Jan 13, 2008 12:27 pm
Location: WrocBaw, France and, Poland
Thanked: 87 times in 58 posts

Re: bugs in MBpost (and SP ?)

Postby Josh Lewis » Tue Sep 17, 2013 9:37 pm

A few other features of Mbpost are missing too. I should make a MbPost tracker as well. :)
My Websites: Alpine Josh · Alpine Ascent · AceMaps
User Avatar
Josh Lewis

 
Posts: 2303
Joined: Thu Jan 06, 2011 11:12 pm
Location: Lynnwood, Washington, The Cloudiest Place on Earth, United States
Thanked: 498 times in 330 posts

Re: bugs in MBpost (and SP ?)

Postby rgg » Wed Sep 18, 2013 3:04 pm

Montana Matt wrote:Yes, I'm not sure why it happens, but some information is not being inserted into the database when photos are uploaded. Thus on the photo page, the code isn't aware of all of the available sizes of photos and it displays the original when it should be displaying the medium resized image.


Talking about image sizes: in the new editor, inserting an image always generates the code for the medium sized version. That's almost always fine, except in those rare occasions where there isn't a medium sized version. I've seen that only a few times, when the original was already relatively small so there was never a need to reduce it to medium anymore.

Another minor point: when resizing an already inserted image in the new editor, from, for example, 500 pixels wide to 970, it would be nice if the medium sized image version would automatically be replaced by the original one if such a version exists. To put it more precisely, upon resizing, it would be nice if the new editor would automatically select the best version available for that new size. For big images this will help to solve the fuzziness, for small ones it improves the speed with which the page will load. Currently I do these adjustments afterwards in the HTML code - unless I forget.
As I said, this is just a minor issue, with a usable work-around, so you may want to spend your valuable time solving other issues. In fact, it seems to me that most people don't resize images, and consequently since the introduction of the new editor the vast majority of images in trip reports are simply the medium sized ones. Smaller ones, which were used frequently in the old editor, seem to have gone out of fashion quickly. I reckon that most people either don't realize they can resize, or just don't bother doing it. I can't say if the same is true for other page types, for while I take at least a quick look at most TR's, I don't do that for the other page types.
User Avatar
rgg

 
Posts: 441
Joined: Sat Oct 02, 2010 7:15 pm
Location: Amsterdam, Netherlands
Thanked: 98 times in 78 posts

Re: bugs in MBpost (and SP ?)

Postby Josh Lewis » Wed Sep 18, 2013 8:30 pm

I agree that image inserting needs to be evaluated for the launch of SPV4. Basically more image sizes are needed than just medium. Same goes for the caption insertions, I'm seeing a lot of "taken on 05/27,2013" in photo captions of pages. This is because they are auto inserted from the image descriptions. Instead of inserting a original, I think a large could handle that just fine but the use of an original if a large does not exist (when the photo is barely 1000px in size).

The new editor takes more work for inserting photos, so I plan on doing some thinking on simplifying the process.
My Websites: Alpine Josh · Alpine Ascent · AceMaps
User Avatar
Josh Lewis

 
Posts: 2303
Joined: Thu Jan 06, 2011 11:12 pm
Location: Lynnwood, Washington, The Cloudiest Place on Earth, United States
Thanked: 498 times in 330 posts

Next

Return to Site Feedback

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

© 2006-2013 SummitPost.org. All Rights Reserved.