Bug RE: width, max-width, and height CSS

Suggestions and comments about SummitPost's features, policies, and procedures. Post bugs here.
User Avatar
Matt Miller
Site Admin
 
Posts: 588
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 194 times in 135 posts

Re: Bug RE: width, max-width, and height CSS

by Matt Miller » Thu Oct 10, 2019 4:01 pm

adventureharder wrote:What is the best/most appropriate method to attach/embed/link an image internally here on the site to avoid broken image URLs?

If the image is uploaded to SummitPost.org, there should be no chance of a broken image URL unless you delete the image yourself or an administrator deletes it.

User Avatar
adventureharder

 
Posts: 16
Joined: Wed Jan 09, 2019 8:50 am
Thanked: 5 times in 5 posts

Re: Bug RE: width, max-width, and height CSS

by adventureharder » Fri Nov 15, 2019 10:20 am

Still struggling with uploading images directly to Summit Post ...

1. The instructions on the bulk image uploader indicate to edit the title in place of the filename. This doesn't appear to work.
2. How do we delete our own images?

In the process of fiddling with this platform, I've uploaded duplicates and none of the intended images have a title (or the correct title). I need to clean them up for housekeeping purposes so I can start over (again) and upload images with the correct title and alt text.

Please help.

User Avatar
Scott
Forum Moderator
 
Posts: 8459
Joined: Thu Aug 21, 2003 1:03 pm
Thanked: 1181 times in 628 posts

Re: Bug RE: width, max-width, and height CSS

by Scott » Fri Nov 15, 2019 1:56 pm

adventureharder wrote:
1. The instructions on the bulk image uploader indicate to edit the title in place of the filename. This doesn't appear to work.
2. How do we delete our own images?

In the process of fiddling with this platform, I've uploaded duplicates and none of the intended images have a title (or the correct title). I need to clean them up for housekeeping purposes so I can start over (again) and upload images with the correct title and alt text.

Please help.


1. It doesn't work for me either. I edit the title after adding the photos.

2. You hit delete and they are marked for deletion. Staff deletes them later.

User Avatar
Matt Miller
Site Admin
 
Posts: 588
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 194 times in 135 posts

Re: Bug RE: width, max-width, and height CSS

by Matt Miller » Fri Nov 15, 2019 8:05 pm

adventureharder wrote:1. The instructions on the bulk image uploader indicate to edit the title in place of the filename. This doesn't appear to work.

Really? I just tested it and it works fine for me. As soon as I click on the current filename, the field becomes active and is able to be changed. See the attached screenshots.
Screenshot 2019-11-15 12.02.44.png
Before editing
Screenshot 2019-11-15 12.02.44.png (172.77 KiB) Viewed 345 times

Screenshot 2019-11-15 12.02.58.png
During editing
Screenshot 2019-11-15 12.02.58.png (173.29 KiB) Viewed 345 times


Is it the case that after editing the name and submitting the images, the names aren't being saved? Or can you not edit them at all in your case?

User Avatar
Scott
Forum Moderator
 
Posts: 8459
Joined: Thu Aug 21, 2003 1:03 pm
Thanked: 1181 times in 628 posts

Re: Bug RE: width, max-width, and height CSS

by Scott » Tue Nov 19, 2019 7:00 pm

Matt Miller wrote:
adventureharder wrote:1. The instructions on the bulk image uploader indicate to edit the title in place of the filename. This doesn't appear to work.

Really? I just tested it and it works fine for me. As soon as I click on the current filename, the field becomes active and is able to be changed. See the attached screenshots.
The attachment $matches[2] is no longer available

The attachment $matches[2] is no longer available


Is it the case that after editing the name and submitting the images, the names aren't being saved? Or can you not edit them at all in your case?


It's working now for me as well.

It still doesn't work using the Add Image Icon, but it works using the Bulk Image Uploader. Before it wasn't working for either (for me at least), but something must be fixed now, at least for the Bulk Image Uploader.

Anyway, if you are curious, here's a screenshot showing that the Add Image Icon still isn't working for image titles and captions (if the caption box is checked, it will just leave a blank shaded box) but since the Bulk Image Uploader seems to be working now, people can use that one instead or edit the titles and captions after the fact.

test 2.JPG
test 2.JPG (25.66 KiB) Viewed 272 times


TEst.JPG
TEst.JPG (43.05 KiB) Viewed 272 times


test 1.JPG
test 1.JPG (80.58 KiB) Viewed 272 times

The following user would like to thank Scott for this post
Matt Miller

User Avatar
adventureharder

 
Posts: 16
Joined: Wed Jan 09, 2019 8:50 am
Thanked: 5 times in 5 posts

Re: Bug RE: width, max-width, and height CSS

by adventureharder » Sat Nov 23, 2019 5:21 am

Using the mouse pointer to rename images didn't do anything at all in the current version of Chrome.

I was attempting to bulk upload images and edit the figures/captions with raw HTM/CSS and that didn't work either.

User Avatar
Matt Miller
Site Admin
 
Posts: 588
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 194 times in 135 posts

Re: Bug RE: width, max-width, and height CSS

by Matt Miller » Sat Nov 23, 2019 4:39 pm

adventureharder wrote:Using the mouse pointer to rename images didn't do anything at all in the current version of Chrome.

Really? I just tried it myself with Chrome Version 78.0.3904.108 and it worked fine.

User Avatar
Scott
Forum Moderator
 
Posts: 8459
Joined: Thu Aug 21, 2003 1:03 pm
Thanked: 1181 times in 628 posts

Re: Bug RE: width, max-width, and height CSS

by Scott » Sat Nov 23, 2019 5:08 pm

adventureharder wrote:Using the mouse pointer to rename images didn't do anything at all in the current version of Chrome.

I was attempting to bulk upload images and edit the figures/captions with raw HTM/CSS and that didn't work either.


Just to make sure, is this where you are clicking?

example.JPG
example.JPG (34.37 KiB) Viewed 214 times


What happens when you click on it?

User Avatar
adventureharder

 
Posts: 16
Joined: Wed Jan 09, 2019 8:50 am
Thanked: 5 times in 5 posts

Re: Bug RE: width, max-width, and height CSS

by adventureharder » Mon Nov 25, 2019 1:42 pm


  1. There is a discrepancy between the page editor preview and the actual page display. It's not a caching issue ... as shown in my video I cleared the cache and hard reloaded my browser window. In addition, the one semi-working image has been posted online for 10 days since my last message.
  2. The ability to rename images from the bulk uploader may (or may not?) be fixed. It worked this time. As mentioned by Scott, I knew where to click before and nothing happened.
  3. I may be blind; however, for the life of me, I can't find a "Delete Image" button to clean up my mess.

On a side note:

  • Is there a feature to subscribe to email notifications for replies to forum messages? I stopped checking this forum thread on an hourly / daily basis after a couple of days and was unaware of the subsequent posts.

User Avatar
Scott
Forum Moderator
 
Posts: 8459
Joined: Thu Aug 21, 2003 1:03 pm
Thanked: 1181 times in 628 posts

Re: Bug RE: width, max-width, and height CSS

by Scott » Wed Nov 27, 2019 11:46 pm



You lost me there. Why are you editing that way (source code)? I'm not saying you can't do it that way, but that seems really complicated. You should be able to click on the photo and edit that way.

I fixed the maps (it only took a few seconds), but I can't follow what/why you are doing the above in the video.

[*]I may be blind; however, for the life of me, I can't find a "Delete Image" button to clean up my mess.[/list]


Click on editor and it's on the right side:

ph1.JPG
ph1.JPG (31.14 KiB) Viewed 118 times


ph2.JPG
ph2.JPG (14.42 KiB) Viewed 118 times

The following user would like to thank Scott for this post
Matt Miller

Previous

Return to Site Feedback

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests