New editor (TinyMCE) -- REPORT BUGS HERE

Suggestions and comments about SummitPost's features, policies, and procedures. Post bugs here.
User Avatar
Montana Matt
Site Admin
 
Posts: 437
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 154 times in 110 posts

New editor (TinyMCE) -- REPORT BUGS HERE

by Montana Matt » Thu Nov 01, 2018 9:14 pm

A new editor was deployed today after much negative feedback and many problems with the newest version of the editor that was put in place earlier this year. That editor was completely removed and I am guessing that no one will miss it.

The new editor has been tested, but not exceptionally thoroughly. Please post any bugs related to the new editor to this thread. Thanks!

User Avatar
Josh Houser

 
Posts: 3337
Joined: Thu Jan 06, 2011 11:12 pm
Thanked: 1019 times in 630 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by Josh Houser » Fri Nov 02, 2018 12:46 am

So far this is my favorite editor I've yet seen implemented on SummitPost. :D Admittedly was already familiar with TinyMCE; out of the box it's pretty darn stable on SP! A few things I noticed:

1. The new menu item File > New Document clears everything off the editor. It should say something like "Clear Entire Page" so that people don't think it's opening a new tab for another page.

new document.png
new document.png (8.5 KiB) Viewed 205 times


As you can see the word choice "New Document" is misleading.

2. When editing an existing photo caption on the page (clicking the photo caption) it turns the photo into an iframe by loading an object with an ID of "tinymce_content_ifr" as seen here:

tinymce.png
tinymce.png (371.17 KiB) Viewed 206 times


Nerdy detail: Checked the editor source code which only shows the figure rather than the newly replaced iframe object. In other words what you see in the screen shot is not actually loaded through the editor unless it cannot detect the iframe from the source.

If the new photo was inserted from the editor editing the caption works just fine. This is regarding existing SP images that were inserted from the "Insert Image from SP" button.

3. Editor > Toolbar > Insert Image from SP or Web The image box clears each time you insert a photo. The ancient editor was great because it would not clear your existing queried search items. Not only does this take more time/effort but is also more taxing on the database per image insertion.

4. Consider consolidating the button "Insert Image from SP or Web". I propose having the "Insert/Edit image" button removed and it's contents parked below the insert page results as seen here:

consolidated.png
consolidated.png (26.78 KiB) Viewed 206 times


This would reduce the number of buttons and make it really easy to go back and forth between inserting photos and uploading new ones. External photos would still be very straight forward. Most of us insert from the site not due to what we are used to; but because page authors often use images from other members or "recycle them" from their TRs, albums, ect.

User Avatar
Montana Matt
Site Admin
 
Posts: 437
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 154 times in 110 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by Montana Matt » Fri Nov 02, 2018 1:01 am

Thanks for the feedback Josh. I read through your post quickly and I might need some clarification on a few things, but I think I can amend the editor to your suggestions that I understand.

It's late and it's been a long day for me. I won't get a chance to do much work for the next couple of days, but I will be back at this on Sunday and trying to fix any bugs reported before then.

User Avatar
Josh Houser

 
Posts: 3337
Joined: Thu Jan 06, 2011 11:12 pm
Thanked: 1019 times in 630 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by Josh Houser » Fri Nov 02, 2018 1:12 am

Added some clarity but it might take a video to explain one of my points. Let me know which one and I'll take a different approach at explaining it. Eventually the Adding image vs Adding Images should be consolidated into a single item which can be done by having an "Attach Existing" link/button on top of the bulk upload as seen here:

Add existing.png
Add existing.png (33.89 KiB) Viewed 195 times

User Avatar
MikeLJ

 
Posts: 8
Joined: Wed Feb 15, 2017 10:22 pm
Thanked: 2 times in 2 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by MikeLJ » Sat Nov 10, 2018 2:23 pm

I have tried to post a new "Mountain/Rock" page to the Branderberger Alpen page.
My first try, I tried to cut and paste some text into the "Overview" but there is no "Paste" option. I tried to remember the keyboard shortcut but was thrown out of SP (Maybe I got that wrong!)
Second/ Third etc.... I just filled in the opening page descriptions and tried to submit. When I click the "Submit" button the view changes to HTML language and only allows me to return to the previous page.
Still no "Paste" option.
The new page is not saved (as fas as I can see).
Am I doing something wrong or is it just not working?.
For what it's worth.... I was fine with the recent editor!
Mike

User Avatar
Montana Matt
Site Admin
 
Posts: 437
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 154 times in 110 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by Montana Matt » Sun Nov 11, 2018 2:54 pm

MikeLJ wrote:My first try, I tried to cut and paste some text into the "Overview" but there is no "Paste" option. I tried to remember the keyboard shortcut

You have to use the following shortcuts:
Ctrl+c = copy
Ctrl+v = paste
Ctrl+x = cut

MikeLJ wrote:but was thrown out of SP (Maybe I got that wrong!)

What was thrown out?

MikeLJ wrote:When I click the "Submit" button the view changes to HTML language and only allows me to return to the previous page.

I can't follow what you're saying in this sentence. Can you clarify?

The following user would like to thank Montana Matt for this post
MikeLJ

User Avatar
MikeLJ

 
Posts: 8
Joined: Wed Feb 15, 2017 10:22 pm
Thanked: 2 times in 2 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by MikeLJ » Sun Nov 11, 2018 3:58 pm

Hi Matt,
I had a few more goes today.
After initially having the same problems - when I created the page and selected "Submit", I was faced with a whole load of HTML script - I then reverted to the "Old" editor to create the page successfully. When I tried the new editor again, it worked at first until I made a change to the summit height and it went wrong again.
I now think that it was because I had typed in an "m" (for metres) which is not needed. Possibly the HTML text was an error message but as I don't usually try to read it I didn't notice?
Either way, once I realised my mistake and corrected it, the new editor worked ok.
When I tried to use "Paste" I got an error message saying my browser is not compatible so I used the keyboard shortcuts and again, all was ok - I must have used the wrong ones before.
I also used the bulk image uploader and it was much quicker.
Sorry for the false alarm.
Mike

User Avatar
Montana Matt
Site Admin
 
Posts: 437
Joined: Tue Sep 01, 2015 3:44 pm
Thanked: 154 times in 110 posts

Re: New editor (TinyMCE) -- REPORT BUGS HERE

by Montana Matt » Sun Nov 11, 2018 6:33 pm

MikeLJ wrote:Possibly the HTML text was an error message but as I don't usually try to read it I didn't notice?

Yes, it was likely an error message due to the "m" entered in a field that should be numbers only. We should add a check to that on the front end with javascript instead of waiting until trying to insert into the database and then throwing an error. I will mark that down as a "to do" item.

I'm glad to hear that you got the rest of the stuff sorted out! Thanks for contributing here and feel free to post again if you have further issues.

The following user would like to thank Montana Matt for this post
MikeLJ


Return to Site Feedback

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest