Report Bugs Here

Suggestions and comments about SummitPost's features, policies, and procedures. Post bugs here.
User Avatar
rgg
Forum Moderator
 
Posts: 862
Joined: Sat Oct 02, 2010 7:15 pm
Thanked: 192 times in 154 posts

Re: Report Bugs Here

by rgg » Mon Nov 04, 2013 7:26 pm

Josh Lewis wrote:The first 5 mountain/rocks do not display: http://www.summitpost.org/mountain/rock/ :? They appear deleted, but some how there are not?


Yes, Buz noted this before, and I went on to figure out which mountains these had been:

rgg wrote:
Buz Groshong wrote:Seems to be something wrong with "Mountains and Rocks." The first five entries have no names and their pictures don't work.


Strange, but I'm not so sure it's a problem with "Mountains and Rocks", because all these five are by SP user nikolai, and the value of Last Edited is Oct 26, 2013 for all of them. So, either he did something to his pages himself or there is a problem specifically for his pages.
Now, if he did it himself, I don't understand why he would delete even the name, yet leave an empty page. Hec, I didn't even know that it was possible to delete the name of an object.

If it is a bug, I hope there is a system backup with which to restore his pages. With a bit of googling, I got this list:

http://www.summitpost.org/flagstaff-hill/228763
http://www.summitpost.org/mcafee-knob/280069
http://www.summitpost.org/harkening-hill/281755
http://www.summitpost.org/kelly-knob/282985
http://www.summitpost.org/rabbit-mountain/764113

I hope this is enough to restore them.


Now I think it's up to Matt to have a look at it.

User Avatar
Josh Houser

 
Posts: 3349
Joined: Thu Jan 06, 2011 11:12 pm
Thanked: 1031 times in 639 posts

Re: Report Bugs Here

by Josh Houser » Tue Nov 05, 2013 2:07 am

Not even the elves can remove those. :o

User Avatar
Scott
Forum Moderator
 
Posts: 8377
Joined: Thu Aug 21, 2003 1:03 pm
Thanked: 1154 times in 608 posts

Re: Report Bugs Here

by Scott » Wed Nov 06, 2013 7:13 pm

Another bug (I cross posted here since I didn't know how many admins read the adoption forum):

http://www.summitpost.org/glossary-summ ... etc/173401

User Avatar
mrchad9

 
Posts: 4531
Joined: Thu Jul 02, 2009 12:01 am
Thanked: 1334 times in 907 posts

Re: Report Bugs Here

by mrchad9 » Wed Nov 06, 2013 8:03 pm

I have encountered the same bug... where the table of contents messed things up. All I could do was revert back to an old version and not make my edits. Couldn't figure it out.

User Avatar
Josh Houser

 
Posts: 3349
Joined: Thu Jan 06, 2011 11:12 pm
Thanked: 1031 times in 639 posts

Re: Report Bugs Here

by Josh Houser » Wed Nov 06, 2013 10:14 pm

It's not a bug, it's setup to do that on purpose. I cleaned up the example above. The reason it does this is because the headers are set to have their own lines. As a result any content below it will be set onto it's own line. In most cases this is just fine. But in cases where there is a huge table of contents and not enough text in the intro to accompany it, it becomes an issue. Please report those cases when they are seen. Don't settle for "gotta go back to the old ways because of this".

In SP V2 the headers had no clear property set to them because they were basic headers with no styling. If I recall right I think we started out with headers without a clear property set to them (basically free flowing and did not have to take up the entire width). The problem with this is that headers would flow through images. :? It was some what rare but happened enough so that adding the "clear" to headers was a recommendation.

So if all goes well for SP V4, things like this (and other reasons) are why I really believe SP needs a full documentation. I'm willing to write it along with any other admin who is willing to help. If organized right there could be a list of common problems which things like this header issue could be listed and explained exactly how to address it. Unlikely folks are going to find it in the forums except for the few who look around for it.

User Avatar
rgg
Forum Moderator
 
Posts: 862
Joined: Sat Oct 02, 2010 7:15 pm
Thanked: 192 times in 154 posts

Re: Report Bugs Here

by rgg » Tue Nov 26, 2013 10:12 am

I think I saw this before but I've forgotten if I mentioned it already: Replies to summit log entries appear in the wrong order. Two examples: http://www.summitpost.org/cotopaxi/climbers-log/150311 and http://www.summitpost.org/lazinser-r-telspitze-cima-rosa/climbers-log/877283.

By looking at it, it appears as if the ordering is by Post date, descending, blissfully ignoring the log entry that it's replying to. That's all right for the log entries themselves, but not for replies. If this is always the case, then a reply always gets displayed somewhere higher than the original post. With a bit of luck, the reply appears right above the original post instead of below it, but it can also end up much higher if other log entries were posted after the original one but before the reply. The only way to make sense of it all is by checking the title of the reply. If it says something like Re: Rebuffed, then look for the original entry titled Rebuffed.

Assuming that there is an SQL query behind this, with an ORDER BY Post_date DESCENDING or ORDER BY Post_id DESCENDING or something similar, I can see that it's actually rather tricky to improve this. Making a few more assumptions, first of all that the database table storing the replies has a reference to the original post, a first attempt would be something like this: ORDER BY COALESCE(reference_id, post_id). This works if reference_id is NULL whenever it's not a reply to anything and the DBMS has a COALESCE function.
However, this is only a partial solution, for it ignores the possibility that there can be replies to replies, and those will still appear in the wrong place. To get it right, the list must be built up as a tree. In SQL that can be done with a recursive query. But if the DBMS behind SP does not support that, then the only solution is to sort the result set of the query after getting it out of the database.

User Avatar
rgg
Forum Moderator
 
Posts: 862
Joined: Sat Oct 02, 2010 7:15 pm
Thanked: 192 times in 154 posts

Re: Report Bugs Here

by rgg » Tue Nov 26, 2013 9:11 pm

With regular comments the ordering seems to be all right, so perhaps something similar could be used for the summit logs and their replies?

User Avatar
JohnMcPike

 
Posts: 51
Joined: Mon Jun 14, 2004 12:34 am
Thanked: 7 times in 5 posts

Re: Report Bugs Here

by JohnMcPike » Tue Dec 03, 2013 2:07 am

for some reason when I go onto SP, I go to sign on and it automatically goes to my page yet I'm not signed on. I;m not allowed to vote on pages or pictures and not able to post any comments whether its on the forum or on a page. Cannot sign out because I'm not signed on. First time this happened I did not go onto SP for 2-3 weeks and it seemed to fiix itself but this time around it did not. I am only able to post this because I am on a different computer.

Hope this makes sense.

User Avatar
Sean Kenney

 
Posts: 410
Joined: Thu Dec 04, 2003 7:04 pm
Thanked: 57 times in 34 posts

Re: Report Bugs Here

by Sean Kenney » Sun Dec 08, 2013 1:39 am

I'm having trouble adding a new topic in on the Southwest US board. When I click "new topic" I'm sent to my profile page. I did try other forums and was directed to the new topic pages for each of the few I sampled.

Thanks,
Sean Kenney.

Update: This appears to be a FIrefox issue. I.E. will allow me to post.

User Avatar
hgrapid

 
Posts: 2750
Joined: Sun Feb 09, 2003 11:34 am
Thanked: 6 times in 5 posts

Re: Report Bugs Here

by hgrapid » Tue Dec 17, 2013 3:11 am

I get messages sent to my inbox from my e-mail. Then I open the e-mail and get this note: "This message was not sent to you. Stop trying to read other people's mail!" It is odd to have that response. It appears punitive or angry at the person who opened it, when it was the site that sent me the mail, not me hacking into Summitpost. Any explanation?

User Avatar
selinunte01

 
Posts: 105
Joined: Thu Nov 20, 2008 4:10 pm
Thanked: 15 times in 14 posts

Re: Report Bugs Here

by selinunte01 » Tue Dec 17, 2013 7:21 am

hgrapid wrote:I get messages sent to my inbox from my e-mail. Then I open the e-mail and get this note: "This message was not sent to you. Stop trying to read other people's mail!" It is odd to have that response. It appears punitive or angry at the person who opened it, when it was the site that sent me the mail, not me hacking into Summitpost. Any explanation?


I do have the same "problem" - it seems to occur when a fake user is deleted previously before I try to open the message (?)

Today it was this one:

Hi selinunte01, akpenejoseph1 just sent you a private message.
You can read the new message here:

http://www.summitpost.org/view_privmsg. ... lder=inbox

If the link does not work, try copying and pasting this link into your web browser:
http://www.summitpost.org/view_privmsg. ... lder=inbox

Have a nice day!

User Avatar
Bob Sihler
Forum Moderator
 
Posts: 8432
Joined: Mon Aug 23, 2004 3:20 pm
Thanked: 2686 times in 1490 posts

Re: Report Bugs Here

by Bob Sihler » Tue Dec 17, 2013 3:24 pm

We're probably going to change that message or do away with it entirely.

Apparently, at least one member has found the message very offensive. People ought to take a deep breath and realize that whoever wrote that message back in the day was probably trying to be a little funny. I seriously doubt it was actually meant to scold or offend.
"Alcohol is like love. The first kiss is magic, the second is intimate, the third is routine. After that you take the girl's clothes off."

--Terry Lennox, The Long Goodbye (Raymond Chandler)

User Avatar
anita

 
Posts: 218
Joined: Fri Jul 17, 2009 2:33 am
Thanked: 909 times in 577 posts

Re: Report Bugs Here

by anita » Tue Dec 17, 2013 10:30 pm

add a smiley to it
then they will understand

sensitive weenies! ;)

The following user would like to thank anita for this post
John Duffield, Josh Houser

User Avatar
Scott
Forum Moderator
 
Posts: 8377
Joined: Thu Aug 21, 2003 1:03 pm
Thanked: 1154 times in 608 posts

Re: Report Bugs Here

by Scott » Fri Dec 20, 2013 3:32 pm

I am about to add five pages to Trinidad and Tobago. Any way we can get the country's name fixed in the dropdown? :wink:

User Avatar
Josh Houser

 
Posts: 3349
Joined: Thu Jan 06, 2011 11:12 pm
Thanked: 1031 times in 639 posts

Re: Report Bugs Here

by Josh Houser » Sat Dec 21, 2013 2:16 am

Scott, you should add that name to the page anyways. If it's a renamed country, Matt can change it's display value from the one you chose right now. But if it's a country that splits into two, then you have a more complicated issue.

But yes, that should be changed. We should generate a list of countries that should be added, changed, or removed. I don't suppose you could help with that? Once it's ready we can put it on the platter for recommending it to Matt. :)

PreviousNext

Return to Site Feedback

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

cron